Invoices Payments are still blocked
Resolved·Partial outage

We think the impact from the issue is over.

Mon, Dec 11, 2023, 04:03 PM
(1 year ago)
·
Affected components
Invoices
Updates

Resolved

We think the impact from the issue is over.

Mon, Dec 11, 2023, 04:03 PM

Identified

During today's incident regarding payment processor, some invoices failed during the paymentWe're fixing them

Mon, Dec 11, 2023, 03:43 PM(19 minutes earlier)

Investigating

We are continuing to investigate this issue.

Mon, Dec 11, 2023, 02:37 PM(1 hour earlier)

Investigating

Invoices Payment are currently blocked

Mon, Dec 11, 2023, 02:36 PM
Powered by