Transaction partner issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 16:05 UTC
Monitoring
The situation seems to have stabilized. We are monitoring.
Posted Nov 13, 2019 - 15:54 UTC
Identified
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.

We suggest carrying a second card or retrying the transaction if it fails.

Thanks for your understanding.
Posted Nov 13, 2019 - 15:04 UTC
This incident affected: 💳 Transactions and 💰 Wallet.