Increasing errors processing transactions
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 22 days ago. Sep 28, 2019 - 20:30 CEST
Monitoring
Mitigating actions have been completed and authorisation processing has been stable since 18:30 UK time. Our payment processor is conducting further checks and will continue to monitor closely.
Posted 22 days ago. Sep 28, 2019 - 19:46 CEST
Update
Investigations of the root cause and mitigating actions continue. However a proportion of authorisations continue to be impacted.
Posted 22 days ago. Sep 28, 2019 - 19:04 CEST
Investigating
We are noticing an increase of errors while processing transactions. We are working closely with our payment provider to resolve the situation. We will update this incident once we have more information.
Posted 23 days ago. Sep 28, 2019 - 18:05 CEST
This incident affected: 💳 Transactions.