Unable to see available funds
Incident Report for Pleo
Resolved
We have pushed out a fix for the bug. Available funds should now work correctly both in the mobile and web app.

Thanks for your patience.
Posted about 2 months ago. Feb 27, 2019 - 11:40 CET
Investigating
We're currently investigating why mobile and web apps have trouble displaying account's available funds.

Will update you as soon as we know more.

Thanks for understanding.
Posted about 2 months ago. Feb 27, 2019 - 10:45 CET
This incident affected: 📱 Application.