Internal processing issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 15:58 UTC
Investigating
Data processing has slowed in some of our services, and export functionality may be impacted for some of our customers.
Posted Jan 13, 2021 - 15:08 UTC
This incident affected: 📱 Mobile application and ⚙️ Pleo API.