Transaction partner issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Apr 23, 2020 - 22:23 CEST
Identified
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.

We suggest carrying a second card or retrying the transaction if it fails.

Thanks for your understanding.
Posted Apr 23, 2020 - 21:16 CEST
This incident affected: 📱 Application, 💳 Transactions, and Card.