Disruption to processing of invoices (planned maintenance)
Incident Report for Pleo
Resolved
Planned maintenance was executed and is now over.
Posted Jan 24, 2023 - 19:30 UTC
Investigating
Our invoice processing service is experiencing some issues. We are currently investigating
Posted Jan 24, 2023 - 18:52 UTC
This incident affected: Invoices.