Report a problem
Subscribe to updates
Report a problem
Subscribe to updates
Some online transactions failing
Resolved
·
Degraded performance
This incident has been resolved.
Tue, Jan 5, 2021, 03:24 PM
(
4
years ago)
·
View all updates
Affected components
Jan 5, 2021, 02:50 PM
03:24 PM
💳 Transactions
Updates
Resolved
This incident has been resolved.
Tue, Jan 5, 2021, 03:24 PM
Investigating
We are currently investigating this issue.
Tue, Jan 5, 2021, 02:50 PM
(
33
minutes earlier)
Powered by