Transaction partner issues
Incident Report for Pleo
Resolved
Our partner has resolved the issue and transactions should be approved as usual now. We will continue to monitor the situation on our end. Sorry for the inconvenience.
Posted Nov 27, 2019 - 15:06 CET
Identified
Our partner has identified the issue and is working on mitigating it.
Posted Nov 27, 2019 - 14:52 CET
Investigating
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.



We suggest carrying a second card or retrying the transaction if it fails.



Thanks for your understanding.
Posted Nov 27, 2019 - 14:44 CET
This incident affected: 💳 Transactions.