Partner issues
Incident Report for Pleo
Resolved
We have identified that a faulty data source reported issues. In fact, no operational issues occurred.
Posted 18 days ago. Oct 03, 2019 - 14:04 CEST
Monitoring
A data source may cause to inaccurately think we had an outage. At the moment, all systems appear operational. We are investigating the data source.
Posted 18 days ago. Oct 03, 2019 - 13:42 CEST
Investigating
Our partner is experiencing issues. This affects transactions and may result in declines. We are doing what we can on our side to mitigate the issue.
Posted 18 days ago. Oct 03, 2019 - 13:32 CEST
This incident affected: 💳 Transactions.