Access failures with mobile and web application and card transaction processing
Incident Report for Pleo
Resolved
Card transaction processing is stable and the issue is now considered successfully resolved.
Our engineers are investigating the root cause of this issue.

We apologize for the inconvenience this may have caused you.
Posted Jan 13, 2023 - 15:18 UTC
Update
Access failures with mobile and web application has been solved and our engineers are investigating the root cause.
Transaction processing is slowly going back to normal activity, our engineers are monitoring and investigating the root cause.
Posted Jan 13, 2023 - 14:56 UTC
Update
We are continuing to investigate this issue.
Posted Jan 13, 2023 - 14:04 UTC
Investigating
Dear customers,
We have identified a technical issue that is impacting a small amount of customers. As a result you may experience issues when making transactions. Our engineers are investigating and monitoring the issue, and are working on providing a fix as soon as possible.

We apologize for the inconvenience this may cause and will keep you posted with new events as they occur.
Posted Jan 13, 2023 - 14:03 UTC
This incident affected: 📱 Mobile application, 💳 Transactions, Card, 🚀 Push notifications, and Web application.