Cards not available in app
Incident Report for Pleo
Resolved
We've resolved the issue previously preventing users from retrieving card details.
Posted Sep 30, 2021 - 10:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 30, 2021 - 10:40 UTC
Investigating
We're experiencing issues retrieving cards details
Posted Sep 30, 2021 - 10:36 UTC
This incident affected: 📱 Mobile application and Card.