Transaction partner issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 21 days ago. Apr 01, 2019 - 16:31 CEST
Identified
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.

We suggest carrying a second card or retrying the transaction if it fails.

Thanks for your understanding.
Posted 21 days ago. Apr 01, 2019 - 15:42 CEST
This incident affected: 📱 Application and 💳 Transactions.