Issues paying invoices
Incident Report for Pleo
Resolved
This is now resolved for customers.
Posted Oct 24, 2024 - 15:02 UTC
Update
We've corrected the error, and are busy monitoring the fix
Posted Oct 24, 2024 - 09:56 UTC
Update
We believe the issue paying invoices is resolved, and are monitoring the situation.
Posted Oct 24, 2024 - 09:50 UTC
Monitoring
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Oct 24, 2024 - 09:48 UTC
Investigating
We've spotted that something has gone wrong and some users are having difficulty paying invoices. We're investigating and hope to have it resolved soon.
Posted Oct 24, 2024 - 08:39 UTC
This incident affected: Invoices.