Unable to view virtual cards
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Apr 11, 2020 - 11:07 CEST
Identified
We've concluded that the issue originates from a faulty API on our payment provider's side. We're waiting for their fix.
Posted Apr 11, 2020 - 10:25 CEST
Investigating
It's currently not possible to view virtual card details. We're investigating the cause.
Posted Apr 11, 2020 - 08:21 CEST
This incident affected: Card.