Pleo is not performing as expected
Resolved
Full outage

We think the impact from the issue is over.

Mon, Mar 4, 2024, 04:26 PM
1 year ago
Affected components
📱 Mobile application
💰 Wallet
🚀 Push notifications
📬 Sign up
📊 Analytics
Expense Creation
Web application
Reimbursements
Out-of-pocket spend functionality
Invoices
Updates

Resolved

We think the impact from the issue is over.

Mon, Mar 4, 2024, 04:26 PM

Monitoring

All Systems are now fully operational

Mon, Mar 4, 2024, 04:25 PM
2h earlier...

Monitoring

Pleo and some of our third party providers and partners are experiencing challenges

Mon, Mar 4, 2024, 01:34 PM
1h earlier...

Monitoring

Systems are operational again with a degraded performance

Mon, Mar 4, 2024, 11:58 AM
1h earlier...

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.

Customers are unable to log in or perform basic tasks.

Mon, Mar 4, 2024, 10:26 AM
Powered by