Card transactions impacted for small amount of customers
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Sep 10, 2022 - 12:43 UTC
Update
We are continuing the investigation of the issue. The expectation is that it will be resolved during the evening. We will continue to share information as soon as there are any new updates.
Posted Sep 10, 2022 - 10:56 UTC
Update
We are continuing to investigate this issue.
Posted Sep 09, 2022 - 19:15 UTC
Investigating
Dear customers,
We have identified a technical issue that is impacting a small amount of customers. As a result you may experience issues when making transactions. Our engineers are investigating and monitoring the issue, and are working on providing a fix as soon as possible.

We apologize for the inconvenience this may cause and will keep you posted with new events as they occur.
Posted Sep 09, 2022 - 19:13 UTC
This incident affected: 💳 Transactions, 💰 Wallet, Card, Reimbursements, Out-of-pocket spend functionality, and Invoices.