Transactions failing and card retrieval is unavailable
Incident Report for Pleo
Resolved
We have identified and resolved the issue with transactions and card retrievals.
Posted Sep 30, 2021 - 12:31 UTC
Update
We are continuing to investigate this issue.
Posted Sep 30, 2021 - 11:22 UTC
Investigating
Many users are reporting inability to retrieve card details in their mobile and web applications.
Posted Sep 30, 2021 - 11:16 UTC
This incident affected: 📱 Mobile application and Card.