Economic export is taking longer than usual
Resolved·Degraded performance

This incident has been resolved

Fri, Apr 1, 2022, 10:01 AM
(3 years ago)
·
Affected components
Updates

Resolved

This incident has been resolved

Fri, Apr 1, 2022, 10:01 AM

Investigating

We are currently investigating the issue

Fri, Apr 1, 2022, 08:36 AM(1 hour earlier)
Powered by