Third party issues causing 3d secure transaction issues
Resolved·Partial outage

This incident has been resolved.

Sun, Jan 10, 2021, 04:36 PM
(4 years ago)
·
Affected components
💳 Transactions
Updates

Resolved

This incident has been resolved.

Sun, Jan 10, 2021, 04:36 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Sun, Jan 10, 2021, 03:24 PM(1 hour earlier)

Investigating

We are currently investigating this issue.

Sun, Jan 10, 2021, 03:21 PM
Powered by