Web interface issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Mar 31, 2020 - 17:08 CEST
Identified
Pleo's web interface (app.pleo.io) is having issues at the moment. We have identified the cause and are working on a fix.

The mobile app is unaffected.
Posted Mar 31, 2020 - 16:51 CEST
This incident affected: 📱 Application.