Resolved
This incident has been resolved.
Investigating
Our Open Banking partner reported experiencing connectivity issues and temporarily disturbance in interacting with some Financial Institutions. UK account Open Banking top-up might be delayed. We apologise for the inconvenience.