Auto top-up functionalities are impacted for EUR customers
Incident Report for Pleo
Resolved
The incident has been resolved
Posted Feb 13, 2024 - 13:54 UTC
Identified
The issue has been identified. Pleo recommends to perform manual top ups instead of relying on Auto Top-Ups.
Pleo is currently in direct communication with their banking partners to fix this issue.
Posted Feb 12, 2024 - 12:28 UTC
Investigating
We are experiencing several issues with Auto Top-Up functionalities. We are investigating the root cause.
Posted Feb 12, 2024 - 10:00 UTC
This incident affected: 💰 Wallet.