Card operation issues
Incident Report for Pleo
Resolved
The situation is now stable. We will continue monitoring this closely.
Posted Apr 22, 2019 - 23:10 CEST
Monitoring
The cause has been identified as a third party provider experiencing issues.
The situation is progressively getting better and we are actively monitoring.

We are sorry for the inconvenience
Posted Apr 22, 2019 - 23:05 CEST
Investigating
Some users might experience issues around locking and unlocking cards, displaying virtual cards and PIN-related operations.

We are looking into it at the moment.
Posted Apr 22, 2019 - 22:57 CEST
This incident affected: 💰 Wallet.