Transaction partner issues
Incident Report for Pleo
Resolved
We are sorry for the inconvenience, everything is back in order
Posted Oct 12, 2019 - 00:04 CEST
Monitoring
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.

We suggest carrying a second card or retrying the transaction if it fails.

Thanks for your understanding.
Posted Oct 11, 2019 - 23:31 CEST
This incident affected: 💳 Transactions.