Partner issues
Incident Report for Pleo
Resolved
All systems have returned to normal
Posted Sep 13, 2019 - 12:36 UTC
Investigating
Our partner is experiencing issues. This affects transactions and may result in declines. We are doing what we can on our side to mitigate the issue.
Posted Sep 13, 2019 - 11:47 UTC
This incident affected: 💳 Transactions.