Transaction partner issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 13 days ago. Apr 09, 2019 - 16:45 CEST
Update
We are continuing to work on a fix for this issue.
Posted 13 days ago. Apr 09, 2019 - 16:44 CEST
Identified
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.

We suggest carrying a second card or retrying the transaction if it fails.

Thanks for your understanding.
Posted 13 days ago. Apr 09, 2019 - 16:16 CEST
This incident affected: 💳 Transactions.