Reimbursements not available for employees on newest app version
Incident Report for Pleo
Resolved
We've fixed the issue and employees should now be able to reimburse directly via the latest Pleo mobile app
Posted Sep 08, 2023 - 09:47 UTC
Identified
We've spotted that something has gone wrong with Reimbursements for employees. We've found the issue and expect it to be solved shortly.
Posted Sep 08, 2023 - 09:14 UTC
This incident affected: Reimbursements.