Issues with mobile and web application
Resolved·Partial outage

This incident has been resolved.

Thu, May 6, 2021, 05:33 AM
(4 years ago)
·
Affected components
📱 Mobile application
💰 Wallet
Updates

Resolved

This incident has been resolved.

Thu, May 6, 2021, 05:33 AM

Investigating

We're currently experiencing issues with some functionalities of the mobile and web app, like viewing of the virtual card or limits. Investigation is in progress.

Sorry for the inconvenience.

Thu, May 6, 2021, 04:29 AM(1 hour earlier)
Powered by