Transaction partner issues
Incident Report for Pleo
Resolved
Our partner has identified and resolved the issue on their end. Everything should be back in working condition. We continue to monitor the situation closely on our end. Sorry for the inconvenience and thank you for your patience.
Posted Jan 14, 2020 - 15:31 UTC
Identified
Our transaction partner is experiencing issues. Card transactions may fail and some features in the application might be unresponsive.

We suggest carrying a second card or retrying the transaction if it fails.

Thanks for your understanding.
Posted Jan 14, 2020 - 14:56 UTC
This incident affected: 📱 Mobile application, 💳 Transactions, and 💰 Wallet.