Performance degradation in the Pleo app
Resolved
Degraded performance

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.

Tue, Jan 30, 2024, 07:46 PM
1 year ago
Affected components
📱 Mobile application
Web application
Updates

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.

Tue, Jan 30, 2024, 07:46 PM
1d earlier...

Monitoring

A fix has been implemented and we are monitoring the results.

Mon, Jan 29, 2024, 06:39 PM
5h earlier...

Identified

We've spotted the cause of this issue. We're currently working on a fix, and will provide an update soon.

Mon, Jan 29, 2024, 12:47 PM
2h earlier...

Investigating

We've spotted that our apps are not performing well. We're currently investigating the issue, and will provide an update soon.

Mon, Jan 29, 2024, 09:57 AM
Powered by