Partnering Bank Integration Issue
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 23:07 UTC
Investigating
Wallet loads for customers with DKK and SEK accounts are currently experiencing issues.
Posted Sep 30, 2021 - 21:57 UTC
This incident affected: 💰 Wallet.