Partner issues
Incident Report for Pleo
Resolved
Our partner identified and successfully mitigated the issue. All systems are operational.
Posted 6 days ago. Sep 11, 2019 - 14:41 CEST
Update
We are continuing to investigate this issue.
Posted 6 days ago. Sep 11, 2019 - 13:34 CEST
Update
We are continuing to investigate this issue.
Posted 6 days ago. Sep 11, 2019 - 13:28 CEST
Investigating
Our partner is experiencing issues. This affects transactions and may result in declines. We are doing what we can on our side to mitigate the issue.
Posted 6 days ago. Sep 11, 2019 - 13:27 CEST
This incident affected: 💳 Transactions.