Degradation in receipt uploading
Incident Report for Pleo
Resolved
The issue has been resolved.
Posted Jul 24, 2023 - 09:00 UTC
Monitoring
A fix has been implemented and we are monitoring its results.
Posted Jul 24, 2023 - 08:33 UTC
Investigating
We have reports of failures when users are uploading receipt PDF due to a recent change.

We are investigating and will provide an update soon.
Posted Jul 24, 2023 - 08:18 UTC