Performance issues on the Pleo apps
Resolved·Partial outage

The issue has been resolved. Our applications are now back to normal performance! We're very sorry for the inconvenience.

Fri, Dec 6, 2019, 04:36 PM
(5 years ago)
·
Affected components
📱 Mobile application
Updates

Resolved

The issue has been resolved. Our applications are now back to normal performance! We're very sorry for the inconvenience.

Fri, Dec 6, 2019, 04:36 PM

Investigating

We are currently investigating performance degradation on Pleo.io impacting our web and mobile apps.

Fri, Dec 6, 2019, 02:55 PM(1 hour earlier)
Powered by