Degraded mobile service
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Nov 08, 2022 - 10:40 UTC
Investigating
We're experiencing degraded service in keeping users logged in on the latest mobile app version. We're working on a new release now with fixes.
Posted Nov 04, 2022 - 13:17 UTC
This incident affected: 📱 Mobile application.