Forward to Pleo temporarily unavailable
Resolved

This incident has been resolved.

Tue, Jan 30, 2024, 07:43 PM
(1 year ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Tue, Jan 30, 2024, 07:43 PM

Investigating

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.

Tue, Jan 30, 2024, 06:14 PM(1 hour earlier)

Investigating

We have had reports of Fetch not working for users. We're currently investigating the issue, and will provide an update soon.

Tue, Jan 30, 2024, 06:11 PM
Powered by