Transaction partner issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 16, 2019 - 22:45 CEST
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Apr 16, 2019 - 22:45 CEST
Identified
Our transaction partner is experiencing issues. Loading money in your wallet and checking your card information.

We suggest carrying a second card or retrying the transaction if it fails.

Thanks for your understanding.
Posted 2 months ago. Apr 16, 2019 - 22:44 CEST
This incident affected: 💰 Wallet.