Direct reimbursements and invoices are temporarily experiencing a degraded experience
Incident Report for Pleo
Resolved
The issue is resolved, and payments are operational again.
Posted Apr 10, 2024 - 12:50 UTC
Identified
We've spotted that something has gone wrong with one of our banking partners. We're currently investigating the issue, and will provide an update soon.
Posted Apr 10, 2024 - 12:07 UTC
This incident affected: Reimbursements and Invoices.