Instant Auto Top Up is temporarily experiencing a degraded experience
Incident Report for Pleo
Resolved
The issue is now resolved, and Instant Auto top-ups are fully operational again.

Some customers, which have been already contacted by Pleo, are required to take actions on their account to grant a renewed Open Banking consent and get their Auto top-up running again.
We apologise for the inconvenience.
Posted May 31, 2024 - 15:39 UTC
Update
We've spotted that something has gone wrong with one of our Open Banking partners and this might result in failed Instant Auto Top Up to the Pleo wallet. We're currently investigating the issue, and will provide an update soon.

We strongly recommend to make use of manual top-up transfers until the outage is fully resolved, thanks.
Posted May 30, 2024 - 08:41 UTC
Investigating
We've spotted that something has gone wrong with one of our Open Banking partners and this might result in failed auto top-ups to the Pleo wallet. We're currently investigating the issue, and will provide an update soon.

We strongly recommend to make use of manual top-up transfers until the outage is fully resolved, thanks.
Posted May 30, 2024 - 08:38 UTC
This incident affected: 💰 Wallet.