Application crashing
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 10:30 CET
Investigating
We're currently investigating an issue affecting our mobile application - crashing on start.
Posted Feb 26, 2020 - 10:20 CET
This incident affected: 📱 Application.