Card information not visible
Incident Report for Pleo
Resolved
It is now possible to view Pleo cards in the web and mobile applications again.
Posted Mar 14, 2022 - 20:54 UTC
Identified
We have resolved the issue in the web application and continue to work on the mobile application.
Posted Mar 14, 2022 - 20:33 UTC
Update
We have resolved the issue in the web application and continue to work on the mobile application.
Posted Mar 14, 2022 - 20:32 UTC
Investigating
Some users are unable to see their Pleo cards in the web and mobile applications. We are investigating and will update as soon as possible.
Posted Mar 14, 2022 - 19:47 UTC
This incident affected: Card.