Wallet top-up are temporarily experiencing a degraded experience
Resolved·Degraded performance

The issue is resolved, and wallet top-ups are fully operational again.

Wed, May 29, 2024, 07:48 AM
(1 year ago)
·
Affected components
💰 Wallet
Updates

Resolved

The issue is resolved, and wallet top-ups are fully operational again.

Wed, May 29, 2024, 07:48 AM

Investigating

We've spotted that something has gone wrong with one of our banking partners and this might result in delayed top-up to the Pleo wallet. We're currently investigating the issue, and will provide an update soon.

Tue, May 28, 2024, 05:58 PM(13 hours earlier)
Powered by