Transactions not appearing in web/mobile application
Incident Report for Pleo
Resolved
Fix has been deployed and new transactions are appearing normally again.

We will make sure the missing transactions also appear in the app during the day.
Posted Oct 15, 2019 - 05:50 UTC
Identified
We're currently fixing an issue with transaction not appearing in our web/mobile application after you complete a transaction. Push notifications are also affected.

Luckily, transactions still process normally and you can continue using your Pleo card.

We will make sure the past transactions appear in the app once this issue is fixed.

Sorry for the inconvenience!
Posted Oct 15, 2019 - 05:26 UTC
This incident affected: 📱 Mobile application and 🚀 Push notifications.