Unable to pair card
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted Oct 28, 2019 - 14:35 CET
Investigating
We are currently experiencing issues in which our users are having difficulty pairing their physical cards.
Posted Oct 28, 2019 - 13:42 CET
This incident affected: Card.