Some customers might experience trouble registering their company
Incident Report for Pleo
Resolved
Customers can now sign up normally.
Posted Mar 15, 2022 - 13:06 UTC
Identified
Some customers might experience trouble registering their company. We have identified the issue and are working on it.
Posted Mar 15, 2022 - 12:50 UTC
This incident affected: 📬 Sign up.