Web application downtime
Incident Report for Pleo
Resolved
The web app is now available again.
Posted Mar 16, 2017 - 13:11 UTC
Identified
Our web application is currently unavailable. It will be restored in a few minutes.

The mobile application still works as expected.
Sorry for the inconvenience.
Posted Mar 16, 2017 - 12:59 UTC