Performance is back to normal.
Incident Report for Pleo
Resolved
The pleo web and mobile apps had degraded performance, but are now back to normal operation.
Posted Nov 20, 2023 - 13:37 UTC
Monitoring
Performance is back to normal, we will continue to monitor the situation.
Posted Nov 20, 2023 - 11:00 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Nov 20, 2023 - 09:49 UTC