Transaction partner issues
Incident Report for Pleo
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 06, 2019 - 14:18 CEST
Monitoring
Our partner has let us know that things are now looking normal on their end.
We continue to monitor the situation on our end.
Thank you for your understanding.
Posted 3 months ago. Jun 06, 2019 - 13:57 CEST
Update
Our partner has identified the cause of the issue and is working to resolve it.
Posted 3 months ago. Jun 06, 2019 - 13:40 CEST
Investigating
Our transaction partner is experiencing issues. This may affect transactions and result in declines. We suggest carrying a second card or retrying the transaction if it fails. Thanks for your understanding.
Posted 3 months ago. Jun 06, 2019 - 13:16 CEST
This incident affected: 💳 Transactions.