Delayed Customer Signup Completion
Resolved·Partial outage

This incident has been resolved

Wed, Apr 28, 2021, 01:12 PM
(4 years ago)
·
Affected components
📬 Sign up
Updates

Resolved

This incident has been resolved

Wed, Apr 28, 2021, 01:12 PM

Identified

New customers will experience a delay in their ability to use Pleo due to an issue we've identified with our third party payment provider.

Wed, Apr 28, 2021, 11:28 AM(1 hour earlier)
Powered by